WAR support is for JRE 1.6 but uses 1.8 classes?

classic Classic list List threaded Threaded
7 messages Options
tom.uijldert tom.uijldert
Reply | Threaded
Open this post in threaded view
|

WAR support is for JRE 1.6 but uses 1.8 classes?

Hi,

I realize JRE 1.6 support is for dinosaurs but still, your Maven pom.xml states that Jolokia supports it.

Consequenty, when I import the (-Jolokia 1.6.0-) sources into an IDE (Eclipse in this case), it complains that "java.beans.Transient" cannot be resolved.
Which makes sense as I understand that that is a 1.8 feature...

Soo... what gives?

TIA,
Tom.
roland roland
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

You are right, this has been slipped in by a PR some time ago. Shouldn't be there, so we have to decided whether to drop 1.6 support or fix this. Would you mind to open an issue over there at github at https://github.com/rhuss/jolokia ?
... roland
tom.uijldert tom.uijldert
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

Done.
See: https://github.com/rhuss/jolokia/issues/388

Given that -for instance- Jboss 5.1.0.GA and older cannot run with JRE 1.8 (I really tried..), this is a kind of catch-22.

OTOH I can settle for a previous version of Jolokia for my situation.
In that case, which version/tag is still 1.6 compliant? and, more importantly, what goodies am I missing in that case?

Thanks,
Tom.
roland roland
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

Thanks. I guess 1.3.2 is safe, at least wrt to the Transient reference.

you can see the changelog at https://jolokia.org/changes-report.html which should give you an impression which has happened since then.

... roland
tom.uijldert tom.uijldert
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

Cheers, I can start with that.

Lots of SSL goodies missing in that case I see and also my favorite, the default enabled authentication in 1.6.0.

I'm thinking of yanking out the "Transient" feature in my own 1.6.0 build, would that be an option?

And I just realised - documentation needs to be updated. The agents overview states that it has been tested to work om jboss 4 and 5...
roland roland
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

I just preparing a PR for 1.6 (did the removal already as well as another 1.6 gotcha), should be available for testing later today. Let's continue to discuss on the GitHub issue, that's easier for me.
... roland
tom.uijldert tom.uijldert
Reply | Threaded
Open this post in threaded view
|

Re: WAR support is for JRE 1.6 but uses 1.8 classes?

Nice.
I'll talk to you later on Github then :)