Jolokia 1.3.3 war under jvm 1.6.0_32

classic Classic list List threaded Threaded
3 messages Options
thebol thebol
Reply | Threaded
Open this post in threaded view
|

Jolokia 1.3.3 war under jvm 1.6.0_32

Hi,

i'm trying to deploy the jolokia war under a tomcat 6.0.36.

The jvm is 1.6.0_32

In the log i get a noclassdeffoundexception for ReflectiveOperationException

java.lang.NoClassDefFoundError: java/lang/ReflectiveOperationException
        at org.jolokia.http.AgentServlet.init(AgentServlet.java:130)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)
        at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:827)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.ha.session.JvmRouteBinderValve.invoke(JvmRouteBinderValve.java:227)
        at org.apache.catalina.ha.tcp.ReplicationValve.invoke(ReplicationValve.java:347)
        at org.apache.catalina.valves.RemoteIpValve.invoke(RemoteIpValve.java:647)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861)
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:606)
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
        at java.lang.Thread.run(Thread.java:662)

Seem like this class is present since Java 7.

There is a jolokia war that can work under jvm 1.6?

Thanks

thebol thebol
Reply | Threaded
Open this post in threaded view
|

Re: Jolokia 1.3.3 war under jvm 1.6.0_32

use the 1.3.2 instead

found here https://github.com/rhuss/jolokia/issues/249
roland roland
Reply | Threaded
Open this post in threaded view
|

Re: Jolokia 1.3.3 war under jvm 1.6.0_32

Yeah, sorry. Seems that a Java 7 class has been slipped in. 'wil fix this for the next version

... roland
... roland